SoulTrader & CrystalSolutions

Tools

The Main Tool Bar

SoulTrader includes a number of menu-options in a tool-bar below the product-title, which you can click to see other available commands. You can also use the standard Short-Cut  keys to access them (for instance, Alt-F for File, Alt-E for Edit, etc.)

Most of the menu-options are provided automatically with the FileMaker database, upon which SoulTrader is based. However, many of these do not have any relevance in this application and thus, have been disabled. A few menu-options (namely Options and Help) have been provided specifically for the application and will no doubt evolve as the product evolves.

The following section describes the menu-options and gives further details where appropriate.

Menu Options

File...

The File menu-option only has one enabled command - Exit, to exit from the application. You can use the key combination Ctrl-Q (or Alt-F, X) to exit SoulTrader . All other commands in this menu-option are disabled.

Edit...

The Edit menu-option contains several enabled commands, such as:

  • Copy & Paste - You can select data in a field and copy it to the clip-board for pasting elsewhere. If you change the style, colour or font of your text, you need to perform a Paste Special. This copies the text-formatting as well as the text.

  • Spelling - You can check the spelling of text, using the Check Record option. Other options include Select Dictionaries (to import an existing or create a new spelling dictionary) and Edit User Dictionary (to add your own entries).

  • Object - Object Links are not used in the current version of the application. Please ignore.

  • Export Field Contents - When the cursor is placed in a particular field, you can export the contents of that field to a file.

  • Preferences - The main purpose for this option is to specify a default User Name for application login. It can also be located from the Setup screens. Other aspects are not described further.

View...

You can use the View menu-option to display or hide a status bar, a text ruler, or to zoom in and out of screens.

Zooming in and out can also be performed with the F3 function key (or Alt-F3 to zoom out).

All other commands in this menu-option are disabled.

Insert...

There are two distinct types of data-field used by SoulTrader ; A Container field and a standard text field.

  • Container fields can hold pictures, music & video files, and links to files & other objects. Objects include such elements as Microsoft Excel spreadsheets, PowerPoint presentations and Flash movies.

  • Standard Text Fields can hold formatted text, dates, times, etc.

Depending on the type of field the cursor is currently in, either container-type or text-type data can be inserted using these menu options.

The From Index and From Last Visited Record commands, retrieve data from the same field in other database records so that you can choose pre-existing data to insert.

Format...

You can select field text and change its font, colour, size, style or alignment.

Similar menu options appear when you right-click on selected text within a field.

Record...

ALL record commands on the tool bar are disabled. If you want to manipulate a record (for instance, add a new one, delete one, etc.) you use the Record Navigation Bar down the right-hand-side of each application screen.

 

Options...

You can use these commands to navigate to the Control Panel, Contacts Page, Support Page or Registration page.

You can also login, exit the application or view the Current Status (for instance, who is logged on, the product status, and usage figures).

 

Window...

A set of standard window commands is provided, to show, hide or minimize windows, tile or cascade them, or to display specific open windows.

In most areas of the application, only one window is opened at any one time.

Help...

Access to the html-based help is achieved by pressing the F1 function key (for context-sensitive help), or by clicking on the Help menu-option and choosing the SoulTrader Help command.

 

 

The Document Window

At the base of the document window are several buttons, to zoom in and out, and to change the operating mode.

However, the operating mode is fixed by SoulTrader . You can see the current operating mode, but may not change it using this button.

The 100 button restores the zoom level to 100 percent.